Translated message

A translation of this page exists in English.

Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

up2date または yum を実行すると、'Abuse of Service' のために RHN アカウントが無効であることを示すメッセージが表示されます

Solution Verified - Updated -

Environment

  • Red Hat Network (RHN) Classic
  • Red Hat Enterprise Linux (RHEL)

Issue

  • yum または up2date を実行しようとすると、"Error Class Code: 49" が発生して失敗します。どのように修正すれば良いですか?

  • up2date または yum を実行すると、'Abuse of Service' のために RHN アカウントが無効であることを示すメッセージが表示されます。どのように対処すれば良いですか?

  • yum install または upgrade を使用すると、以下のエラーが表示されます。

Error Message: 
    Abuse of Service detected for server server1.example.com (123456789) 
Error Class Code:49 
Error Class Info: 
     You are getting this error because RHN has detected an abuse of 
     service from this system and account, This error is triggered when 
     your system makes too many connections to Red Hat Network, This 
     error can not be triggered under a normal use of the Red Hat Network 
     service as configured by default on Red Hat Linux, 

     The Red Hat Network services for this system will remain disabled until 
     you reduce the RHN network traffic from your system to 
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt 
     to contact technical support if you think you have received this message in error

Resolution

これを防ぐには、Red Hat Update Agent poll と、Red Hat Network に 1 時間に 1 回以上アクセスする cron ジョブを一緒に使用しないようにする必要があります。「サービスの不正使用」を検出したためにマシンがブロックされた場合は、以下のいずれかの方法で再度有効にすることができます。

  • ユーザーは、1 日に 100 回確認することができます。ただし、checkin カウンターは、checkin に成功した場合だけでなく失敗したときも増加します。したがって「次の日」まで待つと、システムのブロックが解除され、チェックインが拒否されなくなります。ただし、ユーザーがチェックインに何度も失敗すると、再度チェックインできるようになるために数日かかる場合があることがあります (毎日 100回以上のチェックインの試みている場合)。したがって、システムを再度登録する必要があります。

  • Red Hat Network web インターフェイスにログインし、既存のシステムプロファイルを削除し、システムを再度登録します。システムを登録するには、root ユーザーでマシン上で up2date --register (Red Hat Enterprise Linux 3 または 4 マシンの場合) または rhn_register (Red Hat Enterprise Linux 2.1、3、4、5、または 6 マシンの場合) を実行してシステムプロファイルを再作成します。

Root Cause

システムが最初に Red Hat Network に登録されてから最初の 1500 回チェックイン後は、マシンが Red Hat Network (RHN) に一日に 100 回以上接続した場合にフラグが立ち、この問題が発生します。一週間登録されたマシンは、2200 回チェックインされると拒否されます。

60 分または 120 分ごとにチェックインしても、5 分ごとにチェックインしてもその利点は変わりません。デフォルトのチェックイン間隔 (240 分) で十分でない場合は、cron job または Red Hat Update Agent デーモンを設定して Red Hat Network に 1 時間または 2 時間おきに接続することができます。この設定で十分なはずで、推奨されます。Red Hat Update Agent は、/etc/sysconfig/rhn/rhnsd ファイルの INTERVAL 値を修正することで設定されます。これは、どの間隔 (分) で確認が行われるかを指定します。

また、システムのクローンを作成するまえに、クローンの仮想マシンおよび systemID (/etc/sysconfig/rhn/systemid) を削除していない場合に限りこの問題が発生します。

システムが reposync コマンドを実行している場合は、rhnplugin を使用しているためにエラーメッセージが発生します。

コメント

rhn-virtualization-*12 パッケージがインストールされている Red Hat Enterprise Linux 5 Xen hosts (Dom0) に影響するバグ (Red Hat Bugzilla # 546676) があります。これは、Red Hat エラータ RHBA-2010-003 で修正されました。その後も問題が継続する場合は、Red Hat サポートチームまでご連絡ください。

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments