HAProxy: CVE-2021-40346 on OpenShift Container Platform.

Solution Verified - Updated -

Issue

  • Is OpenShift 4.x vulnerable to CVE-2021-40346 HAProxy vulnerability?
  • Is OpenShift 3.11 vulnerable to CVE-2021-40346 HAProxy vulnerability?
  • How to mitigate CVE-2021-40346 HAProxy vulnerability on OpenShift Container Platform?

Environment

  • Red Hat OpenShift Container Platform
    • 4.X
    • 3.11

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content