Loading tcnative-1 throws: java.lang.UnsatisfiedLinkError: no tcnative-1 in java.library.path

Solution Verified - Updated -

Issue

We are ionstalling the native libraries (jboss-eap-native-6.1.1-win6.x86_64) on JBoss EAP 6.1 to improve the performance of our environment.
It seems to work properly but we find an error related to tcnative-1 library:

2013-10-29 17:28:28 DEBUG [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-1) Loading tcnative-1 throws: java.lang.UnsatisfiedLinkError: no tcnative-1 in java.library.path
2013-10-29 17:28:28 DEBUG [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-1) Loaded: libapr-1
2013-10-29 17:28:28 DEBUG [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-1) Loaded: libeay32
2013-10-29 17:28:28 DEBUG [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-1) Loaded: ssleay32
2013-10-29 17:28:28 DEBUG [org.apache.catalina.core.AprLifecycleListener] (MSC service thread 1-1) Loaded: libtcnative-1
2013-10-29 17:28:28 DEBUG [org.apache.catalina.core] (MSC service thread 1-1) JBWEB001068: Loaded native library 1.1.27 with APR capabilities: IPv6 [true], sendfile [true], random [true]
2013-10-29 17:28:30 DEBUG [org.apache.catalina.core] (MSC service thread 1-1) JBWEB001136: Starting service jboss.web

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP)
    • 6.x
  • Windows

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In