The conditional check 'chrony_installed.rc != 0' failed when upgrading OCP 3.11

Solution Verified - Updated -

Issue

Hosts:    master.example.com
Play:     Install packages necessary for installer
Task:     Install ntp package
Message:  The conditional check 'chrony_installed.rc != 0' failed. The error was: error while evaluating conditional (chrony_installed.rc != 0): 'dict object' has no attribute 'rc'  The error appears to be in '/usr/share/ansible/openshift-ansible/playbooks/init/base_packages.yml': line 16, column 5, but may be elsewhere in the file depending on the exact syntax problem. The offending line appears to be  
# atomic here.
        - name: Install ntp package
          ^ here

Environment

  • Red Hat OpenShift Container Platform 3.11 (RHOCP)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In