Error: 'advanced-virt-for-rhel-8-x86_64-rpms' does not match a valid repository

Solution Verified - Updated -

Issue

  • Error: 'advanced-virt-for-rhel-8-x86_64-rpms' does not match a valid repository ID.
  • Unable to enable the Red Hat Enterprise Linux Advanced Virtualization repository on RHEL 8 systems using the subscription-manager command.
  • While enabling the Red Hat Enterprise Linux Advanced Virtualization repository it shows an invalid error as below.
# subscription-manager repos --enable=advanced-virt-for-rhel-8-x86_64-rpms
Error: 'advanced-virt-for-rhel-8-x86_64-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories.

Environment

  • Red Hat Enterprise Linux 8
  • Red Hat Subscription Management

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In