veeam installation fails because it requires '/usr/bin/python3'

Solution Verified - Updated -

Issue

veeam fails to install on RHEL 7.6 and lower

# yum install veeam
--> Running transaction check
---> Package veeam.x86_64 0:5.0.0.4318-1.el7 will be installed
--> Processing Dependency: veeamsnap = 5.0.0.4318 for package: veeam-5.0.0.4318-1.el7.x86_64
--> Running transaction check
---> Package kmod-veeamsnap.x86_64 0:5.0.0.4318-1.el7 will be installed
--> Processing Dependency: python3 for package: kmod-veeamsnap-5.0.0.4318-1.el7.x86_64
--> Processing Dependency: /usr/bin/python3 for package: kmod-veeamsnap-5.0.0.4318-1.el7.x86_64
--> Processing Dependency: /usr/bin/python3 for package: kmod-veeamsnap-5.0.0.4318-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: kmod-veeamsnap-5.0.0.4318-1.el7.x86_64 (veeam)
           Requires: /usr/bin/python3
Error: Package: kmod-veeamsnap-5.0.0.4318-1.el7.x86_64 (veeam)
           Requires: python3

Environment

Red Hat Enterprise Linux 7.6 and lower

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In