OpenStack 13 to 16.1 In-Place Upgrade Requires New LEAPP Parameters

Solution Unverified - Updated -

Issue

  • When performing an upgrade from OSP13 to OSP16.1 using Red Hat documentation that was posted prior to June 1, 2021, overcloud nodes may be upgraded to RHEL8.4, which is not supported for OSP16.1
  • LEAPP upgrades to RHEL8.2 may fail indicating that certain repositories or RPMs can not be found

Environment

  • Red Hat OpenStack Platform 13
  • Red Hat OpenStack Platform 16.1
  • Red Hat Enterprise Linux 7.9
  • Red Hat Enterprise Linux 8.2
  • Red Hat Ceph 4.2

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In