Satellite upgrade to version 6.9 affects the host group configuration

Solution In Progress - Updated -

Issue

Upgrading Red Hat Satellite server to 6.9.0, 6.9.1 or 6.9.2 from 6.8 or below may result in data loss for host groups with kickstart repositories. This causes issues like provisioning a host with a hostgroup results in:

 ‘Could not create the host: Medium can't be blank‘ 

Customers existing Hostgroups defined in Satellite 6.8 or prior to the upgrade to 6.9 have lost their
their associated:

  • Content View
  • Lifecycle Environment
  • Content Source
  • Kickstart Repository ID

Customers would have to re-associate the values after upgrade which can cause significant impact.

Environment

Satellite 6.9.0, 6.9.1 and 6.9.2 only

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In