Upgrade 16.1.5 - Fail Performing online database updates

Solution In Progress - Updated -

Issue

  • We executing all steps from the beginning are ok until the step 4.7. Performing online database updates from this documentation but it fails with the following error:
Traceback (most recent call last):
  File "<stdin>", line 102, in <module>
  File "<stdin>", line 94, in _ansiballz_main
  File "<stdin>", line 40, in invoke_module
  File "/usr/lib64/python3.6/runpy.py", line 205, in run_module
    return _run_module_code(code, init_globals, run_name, mod_spec)
  File "/usr/lib64/python3.6/runpy.py", line 96, in _run_module_code
    mod_name, mod_spec, pkg_name, script_name)
  File "/usr/lib64/python3.6/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/tmp/ansible_dnf_payload_s8q90a8s/ansible_dnf_payload.zip/ansible/modules/packaging/os/dnf.py", line 1354, in <module>
  File "/tmp/ansible_dnf_payload_s8q90a8s/ansible_dnf_payload.zip/ansible/modules/packaging/os/dnf.py", line 1343, in main
  File "/tmp/ansible_dnf_payload_s8q90a8s/ansible_dnf_payload.zip/ansible/modules/packaging/os/dnf.py", line 1322, in run
  File "/tmp/ansible_dnf_payload_s8q90a8s/ansible_dnf_payload.zip/ansible/modules/packaging/os/dnf.py", line 980, in ensure
  File "/usr/lib/python3.6/site-packages/dnf/module/module_base.py", line 142, in install
    "Installing module from Fail-Safe repository is not allowed"))
dnf.exceptions.Error: Installing module from Fail-Safe repository is not allowed

Environment

  • Red Hat OpenStack Platform 16.1 (RHOSP)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In