yum/rpm update fails due to obsoleted packages

Solution Verified - Updated -

Issue

  • yum/rpm update transaction is failing with dependency error -
  • Example:
Running transaction check
ERROR with transaction check vs depsolve:
rh-eclipse-mvn(org.apache.tika:tika-core) is needed by (installed) rh-eclipse-eclipse-mylyn-docs-epub-3.25.0-0.4.1.el7.noarch
rh-eclipse-mvn(org.apache.tika:tika-parsers) is needed by (installed) rh-eclipse-eclipse-mylyn-docs-epub-3.25.0-0.4.1.el7.noarch
rh-eclipse-osgi(gnu.io.rxtx) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.cdt.core) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.cdt.core.native) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.cdt.native.serial) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.remote.core) is needed by (installed) rh-eclipse-eclipse-launchbar-1:2.4.1-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.remote.core) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.remote.ui) is needed by (installed) rh-eclipse-eclipse-launchbar-1:2.4.1-1.1.el7.noarch
rh-eclipse-osgi(org.eclipse.remote.ui) is needed by (installed) rh-eclipse-eclipse-tm-terminal-connectors-4.5.200-1.1.el7.noarch
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • Red Hat Enterprise Linux 7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In