Gluster yum install/update failing

Solution In Progress - Updated -

Issue

When updating or installing the Gluster server product, yum throws dependency errors similar to:

Error: Package: glusterfs-server-6.0-49.el7rhgs.x86_64 (rh-gluster-3-for-rhel-7-server-rpms)
           Requires: glusterfs-cli(x86-64) = 6.0-49.el7rhgs
           Removing: glusterfs-cli-6.0-37.1.el7rhgs.x86_64 (@rh-gluster-3-for-rhel-7-server-rpms)
               glusterfs-cli(x86-64) = 6.0-37.1.el7rhgs
           Updated By: glusterfs-cli-6.0-49.1.el7.x86_64 (rhel-7-server-rpms)

If you are performing an install, you might see the string:

           Installing: glusterfs-6.0-49.1.el7.x86_64 (rhel-7-server-rpms)

The key is that yum is trying to use a 49.1 package version from either the base RHEL repository (rhel-7-server-rpms) or the RHEL optional repository (rhel-7-server-optional-rpms). There might be other repos that show up too but the key is that the string 6.0-49.1.el7 shows up in the failure output.

Environment

  • RHEL 7.x
  • RHGS 3.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In