AMQ Broker operator is failing to install with the error: 'Service account does not exist'

Solution Verified - Updated -

Issue

  • While trying to install AMQ broker operator from the Operator Hub, the installation fails with the below set of events:
Warning   RequirementsNotMet   clusterserviceversion/amq-broker-operator.v0.18.0   requirements no longer met
Warning   RequirementsNotMet   clusterserviceversion/amq-broker-operator.v0.18.0   requirements no longer met
  • Checking the CSV of amq-broker-operator, below error is seen:
message: Service account does not exist
    name: amq-broker-operator

Environment

  • Red Hat OpenShift Container Platform
    • 4.6

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content