Does fence_aws support IMDSv2 in a Pacemaker cluster?

Solution In Progress - Updated -

Issue

  • My AWS EC2 instances are configured to require the use of IMDSv2 for instance metadata queries. Is the fence_aws fence agent compatible with IMDSv2?
  • fence_aws no longer works after I configured my EC2 instances to require IMDSv2.

Environment

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In