Ansible conflict while upgrading RHVM 4.4.3

Solution In Progress - Updated -


  • After running engine-setup, yum update fails with ansible conflict:
# yum update
Updating Subscription Management repositories.
Last metadata expiration check: 0:00:15 ago on Tue 26 Jan 2021 02:51:38 PM IST.
Dependencies resolved.

 Problem: package ovirt-engine- requires ansible = 2.9.14, but none of the providers can be installed
  - cannot install both ansible-2.9.17-1.el8ae.noarch and ansible-2.9.14-1.el8ae.noarch
  - cannot install the best update candidate for package ovirt-engine-
  - cannot install the best update candidate for package ansible-2.9.14-1.el8ae.noarch
 Package                                          Architecture                                    Version                                                   Repository                                                                   Size
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 ansible                                          noarch                                          2.9.17-1.el8ae                                            ansible-2.9-for-rhel-8-x86_64-rpms                                           17 M

Transaction Summary
Skip  1 Package

Nothing to do.


  • Red Hat Virtualization
  • ovirt-engine-
  • ansible-2.9.14-1.el8ae.noarch

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content