Where are the classes needed to implement a ValidConnectionChecker in JBoss?

Solution Verified - Updated -

Issue

We are currently upgrading our applications to use JBoss EAP 5.1, and we are in need of a new jboss-common-jdbc-wrapper.jar, or relevant jar for the ValidConnectionChecker dependency.

Environment

  • JBoss Enterprise Application Platform EAP 5.1
  • JBoss Enterprise Application Platform EAP 4.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In