Upgrading to Red Hat Satellite 6.8 fails if postgresql-contrib package is installed

Solution Verified - Updated -

Issue

  • The execution of the command satellite-maintain upgrade run --target-version 6.8 fails with an error

    Error: Execution of '/bin/rpm -e postgresql' returned 1: error: Failed dependencies:
        postgresql(x86-64) = 9.2.24-4.el7_8 is needed by (installed) postgresql-contrib-9.2.24-4.el7_8.x86_64
    

Environment

  • Red Hat Satellite 6.8
  • postgresql-contrib

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In