Upgrading Red Hat Satellite server fails with error Procedures::Installer::Upgrade: Could not get default values

Solution Verified - Updated -

Issue

  • Upgrading Red Hat Satellite server from 6.7 to 6.8 fails with below error:

    Running Migration scripts to Satellite 6.8
    ================================================================================
    Setup repositories:
    \ Configuring repositories for 6.8                                    [OK]
    --------------------------------------------------------------------------------
    Unlock packages:                                                      [OK]
    --------------------------------------------------------------------------------
    Update package(s) :                                                   [OK]
    --------------------------------------------------------------------------------
    Procedures::Installer::Upgrade: Could not get default values, check log file at /var/log/foreman-installer/satellite.log for more information
                                          [FAIL]
    Failed executing LANG=en_US.utf-8 satellite-installer  --disable-system-checks, exit status 25
    --------------------------------------------------------------------------------
    Scenario [Migration scripts to Satellite 6.8] failed.
    The following steps ended up in failing state:
      [installer-upgrade]
    

Environment

  • Red Hat Satellite 6.7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In