rhosp-release-16.1.2-2.el8ost.noarch requires podman <= 1.9, but none of the providers can be installed

Solution In Progress - Updated -

Issue

  • With the release of rhosp-release-16.1.2 of today we are having issues installing the latest rhosp-director-images.

  • For deployment we are using a satellite server, with the Red Hat Enterprise Linux 8 for x86_64 - AppStream RPMs 8.2 repo enabled:

  • If i look at the packages for this repo in satellite:

    podman-1.6.4-15.module+el8.2.0+7290+954fb593.x86_64
    podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64
  • podman 1.9.3 seems to be the latest and is installed by undercloud install however the below error is thrown when trying to install rhosp-director-images (after undercloud install), it has a requirement to podman <= 1.9.
    (rhosp-director-images-16.1-20200812.3.el8ost.noarch did not have this requirement):
Depsolve Error occured: \n Problem 1: package rhosp-release-16.1.2-2.el8ost.noarch requires podman <= 1.9, but none of the providers can be installed\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-2.module+el8.1.1+5363+bf8ff1af.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-12.module+el8.2.0+6669+dde598ec.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-11.module+el8.2.0+6368+cf16aa14.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-10.module+el8.2.0+6063+e761893a.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-4.module+el8.1.1+5885+44006e55.x86_64\n  - cannot install both podman-1.4.2-6.module+el8.1.0+4830+f49150d7.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-4.module+el8.1.1+5885+44006e55.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-2.module+el8.1.1+5363+bf8ff1af.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-10.module+el8.2.0+6063+e761893a.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-11.module+el8.2.0+6368+cf16aa14.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-12.module+el8.2.0+6669+dde598ec.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - package rhosp-release-16.1.2-2.el8ost.noarch requires podman >= 1.6.4-15, but none of the providers can be installed\n  - package rhosp-director-images-x86_64-16.1-20201003.1.el8ost.noarch requires rhosp-release > 16.1.2-1, but none of the providers can be installed\n  - package rhosp-director-images-16.1-20201003.1.el8ost.noarch requires rhosp-director-images-x86_64 = 16.1-20201003.1.el8ost, but none of the providers can be installed\n  - cannot install the best candidate for the job\n  - package podman-1.0.0-2.git921f98f.module+el8+2784+9a0c1dfe.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-15.module+el8.2.0+7290+954fb593.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-2.git921f98f.module+el8.0.0+4014+8662b6b2.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-10.module+el8.2.0+6064+4ca4827e.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-2.git921f98f.module+el8.0.0+2956+30df4692.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-11.module+el8.2.0+6369+1f4293b4.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-4.git921f98f.module+el8.2.0+6370+6fb6c8ca.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-3.git921f98f.module+el8.1.0+4241+a7060183.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-4.git921f98f.module+el8.1.0+4908+72a45cef.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-12.module+el8.2.0+6670+014d0ff8.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-16.module+el8.2.0+7659+b700d80e.x86_64 is filtered out by modular filtering\n Problem 2: package rhosp-release-16.1.2-2.el8ost.noarch requires podman <= 1.9, but none of the providers can be installed\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-2.module+el8.1.1+5363+bf8ff1af.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-12.module+el8.2.0+6669+dde598ec.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-11.module+el8.2.0+6368+cf16aa14.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-10.module+el8.2.0+6063+e761893a.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.x86_64\n  - cannot install both podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64 and podman-1.6.4-4.module+el8.1.1+5885+44006e55.x86_64\n  - cannot install both podman-1.4.2-6.module+el8.1.0+4830+f49150d7.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.4.2-5.module+el8.1.0+4240+893c1ab8.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-4.module+el8.1.1+5885+44006e55.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-2.module+el8.1.1+5363+bf8ff1af.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-10.module+el8.2.0+6063+e761893a.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-11.module+el8.2.0+6368+cf16aa14.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - cannot install both podman-1.6.4-12.module+el8.2.0+6669+dde598ec.x86_64 and podman-1.9.3-2.module+el8.2.1+6867+366c07d6.x86_64\n  - package rhosp-release-16.1.2-2.el8ost.noarch requires podman >= 1.6.4-15, but none of the providers can be installed\n  - package rhosp-director-images-x86_64-16.1-20201003.1.el8ost.noarch requires rhosp-release > 16.1.2-1, but none of the providers can be installed\n  - package rhosp-director-images-16.1-20201003.1.el8ost.noarch requires rhosp-director-images-x86_64 = 16.1-20201003.1.el8ost, but none of the providers can be installed\n  - package rhosp-director-images-ipa-16.1-20201003.1.el8ost.noarch requires rhosp-director-images = 16.1-20201003.1.el8ost, but none of the providers can be installed\n  - cannot install the best candidate for the job\n  - package podman-1.0.0-2.git921f98f.module+el8+2784+9a0c1dfe.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-15.module+el8.2.0+7290+954fb593.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-2.git921f98f.module+el8.0.0+4014+8662b6b2.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-10.module+el8.2.0+6064+4ca4827e.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-2.git921f98f.module+el8.0.0+2956+30df4692.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-11.module+el8.2.0+6369+1f4293b4.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-4.git921f98f.module+el8.2.0+6370+6fb6c8ca.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-3.git921f98f.module+el8.1.0+4241+a7060183.x86_64 is filtered out by modular filtering\n  - package podman-1.0.0-4.git921f98f.module+el8.1.0+4908+72a45cef.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-12.module+el8.2.0+6670+014d0ff8.x86_64 is filtered out by modular filtering\n  - package podman-1.6.4-16.module+el8.2.0+7659+b700d80e.x86_64 is filtered out by modular filtering

Environment

  • Red Hat OpenStack Platform 16.1 (RHOSP)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In