CSI Driver installed after upgrade to OpenShift Container Platform 4.6

Solution Verified - Updated -

Issue

  • After upgrading to OpenShift 4.6 we can see that the aws-ebs-csi-driver-operator is now installed. Why is that?
  • After the upgrade from OpenShift Container Platform 4.5 to 4.6 there are now two StorageClasses installed, why?

    $ oc get sc
    NAME            PROVISIONER             RECLAIMPOLICY   VOLUMEBINDINGMODE      ALLOWVOLUMEEXPANSION   AGE
    gp2 (default)   kubernetes.io/aws-ebs   Delete          WaitForFirstConsumer   true                   176m
    gp2-csi         ebs.csi.aws.com         Delete          WaitForFirstConsumer   true                   82m
    

Environment

  • Red Hat OpenShift Container Platform (OCP) 4.6

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In