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Lors de l'exécution d'up2date ou de yum, un message indique que mon compte RHN a été désactivé pour 'Abuse of Service'. Que puis-je faire?

Solution Verified - Updated -

Environment

  • Red Hat Network (RHN) Classic
  • Red Hat Enterprise Linux (RHEL)

Issue

  • Lorsque vous essayez d'exécuter yum ou up2date il échoue avec "Error Class Code: 49". Comment résoudre ce problème?

  • Lors de l'exécution d'up2date ou de yum, un message indique que mon compte RHN a été désactivé pour 'Abuse of Service'. Que puis-je faire?

  • En utilisant yum install ou upgrade j'obtiens l'erreur suivante:

Error Message:
    Abuse of Service detected for server server1.example.com (123456789)
Error Class Code: 49
Error Class Info:
     You are getting this error because RHN has detected an abuse of
     service from this system and account, This error is triggered when
     your system makes too many connections to Red Hat Network, This
     error can not be triggered under a normal use of the Red Hat Network
     service as configured by default on Red Hat Linux,

     The Red Hat Network services for this system will remain disabled until
     you reduce the RHN network traffic from your system to
     acceptable limits.

     Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
     to contact technical support if you think you have received this message in error

Resolution

Pour éviter cela, nous devons nous assurer qu'il n'y a pas de combinaisons de Red Hat Update Agent et de tâches cron qui accèdent au Red Hat Network avec une fréquence plus grande qu'une fois toutes les heures. Dans le cas où un serveur a été bloqué en raison d'un abus de service, il peut être réactivé par deux moyens:

  • Un utilisateur obtient 100 vérifications par jour.Par contre le compteur est incrémenté par les tentatives de connections échouées et réussies. Ainsi on peut attendre a "demain" de sorte que le système soit débloqué et devrait être autorisé a nouveau sans être rejeté.Mais parfois, il est possible que l'utilisateur a tellement fait de tentatives échouées qu'il faudrait plusieurs jours ( avec chaque jour qui fourni 100 tentatives de plus) pour l'utilisateur à être autorisés à nouveau.Ainsi, l'utilisateur aura besoin de ré-enregistrer le système.

  • Connectez-vous a l'interface web de Red Hat Network , supprimer le profil du système existant, et ré-enregistrer le système. Pour enregistrer le système, exécuter soit up2date --register (pour Red Hat Enterprise Linux 3 ou 4 ) ou rhn_register (pour Red Hat Enterprise Linux 2.1, 3, 4, 5, ou 6) sur la machine en tant que root afin de recréer le profil du système.

Root Cause

Cela se produit quand une machine est signalée en se connectant au Red Hat Network (RHN) plus fréquemment que 100 fois par jour après les 1500 premiers "check-ins" depuis que le système a été enregistré avec Red Hat Network. Un serveur qui a été enregistré pendant une semaine serait rejeté après 2200 check-ins.

Il n'y a aucun avantage à vérifier toutes les 5 minutes versus vérifier toutes les 60 ou 120 minutes. Si le check-in par défaut; avec un intervalle de 240 minutes ne suffit pas, alors vous pouvez configurer des tâches cron ou le daemon Red Hat Update Agent pour se connecter au Red Hat Network toutes les heures , ce qui devrait suffire et est recommandé. L'agent Red Hat Update est configuré en éditant le fichier /etc/sysconfig/rhn/rhnsd, vous pouvez modifier la valeur INTERVAL, qui indique le nombre de minutes entre les vérifications.

Cela peut également se produire si le système est une machine virtuelle clonée et le systemID (/etc/sysconfig/rhn/systemid) n'a pas été retiré avant le clonage du système.

Si le système était en cours d'exécution d'une commande reposync, cela peut aussi provoquer le message d'erreur, car il utilise le rhnplugin

Commentaires

Il y avait un bug (Red Hat Bugzilla # 546676) affectant les hôtes Xen (dom0) sous Red Hat Enterprise Linux 5 avec les paquetages rhn-virtualization-*12 installés qui ont été fixés avec l'errata de Red Hat RHBA-2010-003. Si le problème persiste encore , n'hésitez pas à contacter le support technique de Red Hat.

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