yum is unable to install an intermediate update requiring a package release ending in 'el6' when packages are available with release '.el6_xyz'

Solution Verified - Updated -

Issue

  • yum is unable to install an intermediate update requiring a package release ending in 'el6' when packages are available with release '.el6_xyz'
  • yum tries to install packages from another architecture while not expected while updating a package ending in '.el6'

Environment

  • Red Hat Enteprise Linux 6 with yum :
# yum --version
3.2.29
  Installed: rpm-4.8.0-32.el6.x86_64 at 2013-09-03 16:17
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2012-11-15 14:22
  Committed: Florian Festi <ffesti@redhat.com> at 2012-11-15

  Installed: yum-3.2.29-40.el6.noarch at 2013-09-03 16:17
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2013-01-08 17:02
  Committed: James Antill <james.antill@redhat.com> at 2013-01-08

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In