Cannot install ruby gems: copy_file_range not supported

Solution Verified - Updated -

Issue

  • Users are using the software collection rh-ruby26 and trying to install gems and getting errors:

/opt/rh/rh-ruby26/root/usr/share/ruby/fileutils.rb:503:in `copy_stream': Operation not supported - copy_file_range (Errno::ENOTSUP).

Environment

  • Red Hat Enterprise Linux 7.8 or later

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In