Capsule upgrade fails with 'pulp-gen-ca-certificate returned 1 instead of one of [0]' error

Solution Verified - Updated -

Issue

  • Capsule upgrade fails with below error:

     /Stage[main]/Pulp::Config/Exec[run pulp-gen-ca]/returns: change from notrun to 0 failed: /usr/bin/pulp-gen-ca-certificate returned 1 instead of one of [0]
     /Stage[main]/Pulp::Config/Exec[run pulp-gen-ca]: Failed to call refresh: 
     /usr/bin/pulp-gen-ca-certificate returned 1 instead of one of [0]
     /Stage[main]/Pulp::Config/Exec[run pulp-gen-ca]: /usr/bin/pulp-gen-ca-certificate returned 1 instead of one of [0]
     /usr/share/ruby/vendor_ruby/puppet/util/errors.rb:106:in `fail'
    

Environment

  • Red Hat Satellite 6.x
  • Red Hat Satellite Capsule 6.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In