How to install RPM packages from earlier RHEL versions on a FIPS-enabled system?

Solution In Progress - Updated -

Issue

  • How to install RPM packages on a FIPS-enabled system that were built on RHEL 7 or earlier?
  • YUM fails with the following error:
    package <package> does not verify: no digest
    when running in FIPS mode

Environment

  • Red Hat Enterprise Linux 8
  • FIPS mode
  • RPM packages from RHEL 7 or earlier

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In