mod_ssl-2.2.26 is not compatible with JBCS OpenSSL

Solution Verified - Updated -

Issue

  • We are trying to update or install mod_ssl for EWS 2 httpd, but there are dependency errors when we the JBCS repository is enabled as well:
# yum install mod_ssl
Loaded plugins: enabled_repos_upload, package_upload, product-id, search-disabled-repos, security, subscription-manager
Setting up Install Process
jb-coreservices-1-for-rhel-6-server-rpms                                                                                                                                                        | 2.3 kB     00:00
Loaded plugins: enabled_repos_upload, package_upload, product-id, search-disabled-repos, security, subscription-manager
Setting up Install Process
jb-coreservices-1-for-rhel-6-server-rpms                                                                                                                                                        | 2.3 kB     00:00
jb-eap-6-for-rhel-6-server-rpms                                                                                                                                                                 | 2.0 kB     00:00
rhel-6-server-extras-rpms                                                                                                                                                                       | 1.8 kB     00:00
rhel-6-server-optional-rpms                                                                                                                                                                     | 2.0 kB     00:00
rhel-6-server-rh-common-rpms                                                                                                                                                                    | 2.1 kB     00:00
rhel-6-server-rpms                                                                                                                                                                              | 2.0 kB     00:00
rhel-6-server-satellite-tools-6.5-rpms                                                                                                                                                          | 2.1 kB     00:00
rhel-6-server-supplementary-rpms                                                                                                                                                                | 2.0 kB     00:00
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.2.26-57.ep6.el6 will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: 1:mod_ssl-2.2.26-57.ep6.el6.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.2.26-57.ep6.el6.x86_64 (jb-eap-6-for-rhel-6-server-rpms)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
           Available: 1:jbcs-httpd24-openssl-libs-1.0.2h-4.jbcs.el6.x86_64 (jb-eap-6-for-rhel-6-server-rpms)
               libcrypto.so.10(OPENSSL_1.0.2)(64bit)

Environment

  • JBoss Enterprise Web Server (EWS) 2.x
    • httpd 2.2.26
  • JBoss Core Services (JBCS) OpenSSL

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In