"require_membership_of" option doesn't work for shortnames (users/groups) anymore after upgrading to samba-4.10.4-10.el7.x86_64.

Solution Verified - Updated -

Issue

  • require_membership_of option in pam_winbind.conf file doesn't work for shortnames (users/groups) anymore with samba-4.10.4-10.el7.x86_64.
  • require_membership_of option doesn't work for shortnames (users/groups) anymore after upgrading to samba-4.10.4-10.el7.x86_64.
  • require_membership_of option for pam_winbind fails when using samba-4.10.4-10.el7.x86_64.
Apr  1 12:00:18 rhel7test sshd[3065]: pam_winbind(sshd:auth): could not lookup name: adgroupname
Apr  1 12:00:18 rhel7test sshd[3065]: pam_winbind(sshd:auth): cannot convert group adgroupname to sid, check if group adgroupname is valid group.

Environment

  • Red Hat Enterprise Linux 7
  • samba-4.10.4-10.el7.x86_64

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In