In a vnc session, user can not input password at gnome login screen with ”Authentication error” messages

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux 8.1
  • tigervnc-server-1.9.0-15.el8_1.x86_64

Issue

For the users who setup the vnc service follow the way provided by /usr/lib/systemd/user/vncserver@.service.
How to configure VNC Server in Red Hat Enterprise Linux 8?

  • In a vnc session, after Screen Lock occurred, user can not input password .
  • ”Authentication error” message shows up under the password input box.

login screen

Resolution

  • Bug#1827469 has been filed against this issue.

  • As a vnc user, ssh to the vnc server, do

$ vncserver -kill :<display No. of user session> 
$ vncserver :<the same display No. you just killed> 

can somehow be a workaround. The issue won't show up again until the next OS reboot.

  • The procedure used on RHEL 7 also works on RHEL 8. It is another option for users to setup vnc server.
/usr/lib/systemd/system/vncserver@.service
# The vncserver service unit file
#
# Quick HowTo:
# 1. Copy this file to /etc/systemd/system/vncserver@.service
# 2. Replace <USER> with the actual user name and edit vncserver
#    parameters in the wrapper script located in /usr/bin/vncserver_wrapper
# 3. Run `systemctl daemon-reload`
# 4. Run `systemctl enable vncserver@:<display>.service`
#

Also see, How to configure VNC Server in Red Hat Enterprise Linux 7

Root Cause

  • From RHEL 8, a user systemd service file "/usr/lib/systemd/user/vncserver@.service" provides a way for non-root users to configure the vnc service. But Screen Lock triggers this login issue.
  • Component
  • vnc

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments