Why ose-ansible-v3.11.170 has old version of Ansible-2.6?

Solution In Progress - Updated -

Issue

  • A quick check of ose-ansible-v3.11.170 image shows, it still using the old version of Ansible-2.6.
  • The minimum version of Ansible required for OpenShift Container Platform 3.11 to run playbooks is now 2.8.x. Why
    ose-ansible-v3.11.170 image has still the old version?
  • Some security scan tools may report vulnerabilities for an older version of Ansible inside ose-ansible.

Environment

  • Openshift Container Platform
    v3.11

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In