Unable to install patch feature on Karaf child container (non-Fabric env)

Solution Verified - Updated -

Issue

It is not possible to patch Karaf child container (container got created using admin:create Karaf command) in a non-Fabric environment.
Patching the patch mechanism on Karaf child container fails with:

Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.patch.patch-core [63]: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=org.eclipse.jgit.api.errors)

Environment

  • Red Hat Fuse 6.3
  • using admin:create to create child container
  • non-Fabric environment
  • Patch installation

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In