Admin console is not available during Domain Controller start up in the JBoss EAP 7

Solution Verified - Updated -

Environment

Red Hat JBoss Enterprise Application Platform (EAP) 7.x

Issue

Web console is only available after all servers are registered in the Domain Controller. If Domain Controller is started with all servers to auto-start="true", the web console is not available until all servers are registered and the browser prompts to add a new interface.

Resolution

To workaround the issue, do not configure managed servers to the Domain Controller. The Jira related in Root Cause section points to an enhancement for JBoss EAP 7.2 CP 8. Red Hat recommends keeping environments updated.

Root Cause

There is a Jira JBEAP-15235 opened to cover this issue.

Diagnostic Steps

Configure a Domain Controler and one Host Controller (slave) and add a few servers to Domain Controller. Start up both, the Domain Controller and remote Host Controller at the same time.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments