Cannot upgrade from RHGS 3.3.1 to RHGS 3.5 using the ISO image - Error: Package: vdsm-cli

Solution Verified - Updated -

Issue

On my repolist I don't have access to external repos, so I have downloaded the RHGS 3.5 ISO "rhgs-3.5-rhel-7-x86_64-dvd-1.iso" and configured as a local repository:

[root@gluster0example yum.repos.d]# yum repolist enabled
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
This system is not registered with an entitlement server. You can use subscripti                                                                                                 on-manager to
 register.
InstallMedia                                             | 3.8 kB     00:00
(1/2): InstallMedia/group_gz                               | 6.4 kB   00:00
(2/2): InstallMedia/primary_db                             | 1.7 MB   00:00
repo id       repo name                                                   status
InstallMedia  Red Hat Gluster Storage 3.5 for Red Hat Enterprise Linux 7  1,168
repolist: 1,168

If i try to upgrade my server with RHGS 3.3.1 to RHGS 3.5 using this ISO , I get some dependency errors with package "vdsm-cli" , so I cannot proceed with the upgrade.

[root@gluster0example yum.repos.d]# yum update
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package GeoIP.x86_64 0:1.5.0-11.el7 will be updated
---> Package GeoIP.x86_64 0:1.5.0-14.el7 will be an update
--> Processing Dependency: geoipupdate for package: GeoIP-1.5.0-14.el7.x86_64
...
...
---> Package tendrl-commons.noarch 0:1.6.3-21.el7rhgs will be an update
--> Processing Dependency: python2-pyasn1 <= 0.1.9 for package: tendrl-commons-1.6.3-21.el7rhgs.noarch
---> Package vdsm-python.noarch 0:4.17.33-1.2.el7rhgs will be updated
--> Processing Dependency: vdsm-python = 4.17.33-1.2.el7rhgs for package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch
---> Package vdsm-xmlrpc.noarch 0:4.17.33-1.2.el7rhgs will be obsoleted
--> Processing Dependency: vdsm-xmlrpc = 4.17.33-1.2.el7rhgs for package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch
--> Running transaction check
---> Package mtools.x86_64 0:4.0.18-5.el7 will be installed
---> Package perl-hivex.x86_64 0:1.3.10-6.9.el7 will be installed
---> Package tendrl-commons.noarch 0:1.6.3-21.el7rhgs will be an update
--> Processing Dependency: python2-pyasn1 <= 0.1.9 for package: tendrl-commons-1.6.3-21.el7rhgs.noarch
---> Package vdsm-python.noarch 0:4.17.33-1.2.el7rhgs will be updated
--> Processing Dependency: vdsm-python = 4.17.33-1.2.el7rhgs for package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch
---> Package vdsm-xmlrpc.noarch 0:4.17.33-1.2.el7rhgs will be obsoleted
--> Processing Dependency: vdsm-xmlrpc = 4.17.33-1.2.el7rhgs for package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch
--> Finished Dependency Resolution
Error: Package: tendrl-commons-1.6.3-21.el7rhgs.noarch (InstallMedia)
           Requires: python2-pyasn1 <= 0.1.9
           Installed: python2-pyasn1-0.3.7-2.el7rhgs.noarch (@anaconda/3.3.1)
               python2-pyasn1 = 0.3.7-2.el7rhgs
           Available: python2-pyasn1-0.1.9-7.el7.noarch (InstallMedia)
               python2-pyasn1 = 0.1.9-7.el7
Error: Package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch (@anaconda/3.3.1)
           Requires: vdsm-xmlrpc = 4.17.33-1.2.el7rhgs
           Removing: vdsm-xmlrpc-4.17.33-1.2.el7rhgs.noarch (@anaconda/3.3.1)
               vdsm-xmlrpc = 4.17.33-1.2.el7rhgs
           Obsoleted By: vdsm-http-4.30.18-1.0.el7rhgs.noarch (InstallMedia)
               vdsm-xmlrpc = 4.30.18-1.0.el7rhgs
Error: Package: vdsm-cli-4.17.33-1.2.el7rhgs.noarch (@anaconda/3.3.1)
           Requires: vdsm-python = 4.17.33-1.2.el7rhgs
           Removing: vdsm-python-4.17.33-1.2.el7rhgs.noarch (@anaconda/3.3.1)
               vdsm-python = 4.17.33-1.2.el7rhgs
           Updated By: vdsm-python-4.30.18-1.0.el7rhgs.noarch (InstallMedia)
               vdsm-python = 4.30.18-1.0.el7rhgs
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@gluster0example yum.repos.d]# 

If I try to use the yum update --skip-broken to workaround the problem , the result is 448 packages are skipped...which does not seems good

About the Error: Package: tendrl-commons , there is a workaround for the tendrl-commons package reported the on the RHGS 3.5 Release Notes (BZ 1645428)

About the Error: Package: vdsm-cli
Q. Is there any way to workaround of fix this dependency problem with vdsm-cli ?

Environment

  • Red Hat Gluster Storage Server 3.3.1

    • glusterfs-server-3.8.4-52.el7rhgs.x86_64
  • Red Hat Gluster Storage Server 3.5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In