Using the RHDM / RHPAM 7.5.1 update tool fails with InvalidVersionException

Solution In Progress - Updated -

Issue

Trying to upgrade a system from 7.5.0 to 7.5.1 fails with the following error:

$ ./apply-updates.sh /path/to/rhdm750/standalone/deployments/kie-server.war rhdm-kie-server-ee8
...
21:35:01.696 [main] ERROR - Error occurred during the execution!
org.jboss.brmsbpmsuite.patching.client.InvalidVersionException: The patch is not valid for the distribution and version!
    at org.jboss.brmsbpmsuite.patching.client.GeneralDistributionPatcher.checkVersion(GeneralDistributionPatcher.java:48)
    at org.jboss.brmsbpmsuite.patching.phase.DistributionPatchingPhaseRunner.run(DistributionPatchingPhaseRunner.java:24)
    at org.jboss.brmsbpmsuite.patching.client.ClientPatcherRunner.runPhases(ClientPatcherRunner.java:73)
    at org.jboss.brmsbpmsuite.patching.client.ClientPatcherRunner.runDistributionPatcher(ClientPatcherRunner.java:61)
    at org.jboss.brmsbpmsuite.patching.client.ClientPatcherRunner.run(ClientPatcherRunner.java:38)
    at org.jboss.brmsbpmsuite.patching.client.ClientPatcherApp.commonMain(ClientPatcherApp.java:53)
    at org.jboss.brmsbpmsuite.patching.client.BPMSuiteClientPatcherApp.main(BPMSuiteClientPatcherApp.java:6)

Environment

  • Red Hat Decision Manager (RHDM)
    • 7.5.1
  • Red Hat Process Automation Manager (RHPAM)
    • 7.5.1

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In