pg_dump falied with "aborting because of server version mismatch"

Solution Verified - Updated -

Issue

We recently upgraded our PostgreSQL database from 8.4 to 9.2, and now we try to run the pg_dump command, we get this error:

pg_dump: server version: 9.2.4; pg_dump version: 8.4.13
pg_dump: aborting because of server version mismatch

Does the cartridge still have the old version of pg_dump, or do we need to run some sort of upgrade process? We are using python 3.3 as framework cartridge.

Environment

  • OpenShift Online
  • Python 3.3 cartridge

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In