Unable to install katello-agent on RHEL 8 system registered to Red hat Satellite 6.

Solution Verified - Updated -

Issue

  • RHEL 8 hosts fail to install katello-agent, and the following error messages are generated:
    Problem: package katello-agent-3.5.0-2.el8sat.noarch requires python3-gofer-proton, but none of the providers can be installed
    package python3-gofer-proton-2.12.5-3.el8sat.noarch requires python3-qpid-proton >= 0.9-5, but none of the providers can be   installed
    conflicting requests
    nothing provides python3 needed by python3-qpid-proton-0.26.0-3.el8.x86_64 
    (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Environment

  • Red Hat Enterprise Linux 8
  • Red Hat Satellite 6.5 and Above

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In