RHAMT Eclipse plugin installation gives dependency errors

Solution Verified - Updated -

Issue

  • When installing the RHAMT plugin the below error is given:
Cannot complete the install because one or more required items could not be found.
  Software being installed: RHAMT 4.2.1.Final (org.jboss.tools.windup.feature.feature.group 4.2.1.Final)
  Missing requirement: Windup Core 4.2.1.Final (org.jboss.tools.windup.core 4.2.1.Final) requires 'osgi.bundle; org.jboss.tools.common 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: RHAMT 4.2.1.Final (org.jboss.tools.windup.feature.feature.group 4.2.1.Final)
    To: org.eclipse.equinox.p2.iu; org.jboss.tools.windup.core [4.2.1.Final,4.2.1.Final]

Environment

  • Red Hat Application Migration Toolkit (RHAMT) 4.2
  • RHAMT Eclipse Plugin

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In