Generating an ansible inventory from the undercloud

Solution Verified - Updated -

Issue

  • The openstack inventory plugin requires python-shade which isn't available in the Red Hat OpenStack 10 repositories.
  • We can't install the python-shade package in a Red Hat OpenStack Platform 10 undercloud because of the failed dependencies.

Environment

  • Red Hat OpenStack Platform 10

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In