"Client connection failed" warnings from HornetQ in JBoss EAP

Solution Unverified - Updated -

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP)
    • 6

Issue

  • We are seeing these warning message in our log. What do they mean?
WARN  [org.hornetq.core.protocol.core.impl.RemotingConnectionImpl] (hornetq-failure-check-thread) Connection failure has been detected: Did not receive data from /host:port. It is likely the client has exited or crashed without closing its connection, or the network between the server and client has failed. You also might have configured connection-ttl and client-failure-check-period incorrectly. Please check user manual for more information. The connection will now be closed. [code=3]
WARN  [org.hornetq.core.server.impl.ServerSessionImpl] (hornetq-failure-check-thread) Client connection failed, clearing up resources for session <uuid>
WARN  [org.hornetq.core.server.impl.ServerSessionImpl] (hornetq-failure-check-thread) Cleared up resources for session <uuid>

Resolution

  • Ensure all clients are properly closing their connections to the server when they exit. This is typically done in a finally block.

  • Inspect the network for any issues that might cause clients to become disconnected from the server. Consider adjusting the <connection-ttl> (default is 60000ms) and <check-period> (default is 30000ms) on the appropriate JMS connection factory. If network latency is the problem then increasing these values will help mitigate this issue.

Root Cause

  • These messages indicate a problem with a client's connection to the server. When the server determines that a client is no longer responding it cleans up the server-side resources related to the client's connection and issues these warnings.

  • This could be caused by clients which are not properly coded to close their resources when they exit, network problems which break the connection, etc.

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