JBoss EAP 7.0 to 7.2 RPM Upgrade Fails on weld-api.jar Dependency Error

Solution Verified - Updated -

Issue

  • When upgrading, I see the following dependency error:

    Transaction Check Error:
        file /opt/rh/eap7/root/usr/share/java/weld-api.jar from install of eap7-jboss-weld-3.0-api-weld-api-0:3.0.0-7.SP4_redhat_00001.1.el6eap.noarch conflicts with file from package eap7-jboss-weld-2.2-api-0:2.3.0-7.SP1_redhat_1.1.ep7.el6.noarch
        file /opt/rh/eap7/root/usr/share/java/weld-spi.jar from install of eap7-jboss-weld-3.0-api-weld-spi-0:3.0.0-7.SP4_redhat_00001.1.el6eap.noarch conflicts with file from package eap7-jboss-weld-2.2-api-0:2.3.0-7.SP1_redhat_1.1.ep7.el6.noarch
        file /opt/rh/eap7/root/usr/share/java/weld-spi-sources.jar from install of eap7-jboss-weld-3.0-api-weld-spi-0:3.0.0-7.SP4_redhat_00001.1.el6eap.noarch conflicts with file from package eap7-jboss-weld-2.2-api-0:2.3.0-7.SP1_redhat_1.1.ep7.el6.noarch
        file /opt/rh/eap7/root/usr/share/java/weld-api-sources.jar from install of eap7-jboss-weld-3.0-api-weld-api-0:3.0.0-7.SP4_redhat_00001.1.el6eap.noarch conflicts with file from package eap7-jboss-weld-2.2-api-0:2.3.0-7.SP1_redhat_1.1.ep7.el6.noarch
    

Environment

  • Red Hat JBoss Enterprise Application Platform (JBoss EAP)
    • 7.0
    • 7.2
  • Red Hat Single Sign-On (RH-SSO)
    • 7.1
    • 7.3
  • Red Hat Enterprise Linux (RHEL)
    • 6
  • RPM Package Manager (RPM) installation

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In