Generated Fues 7.2 BOM for Fuse Integration project is not correct

Solution Verified - Updated -

Issue

Generated Fues 7.2 BOM for Fuse Integration project is not correct.

wrong version

  <properties>
    ...
    <jboss.fuse.bom.version>7.2.0.fuse-720020-redhat-00001</jboss.fuse.bom.version>
    ...
  </properties>
  <dependencyManagement>
    <dependencies>
      <dependency>
        <groupId>org.jboss.fuse</groupId>
        <artifactId>jboss-fuse-parent</artifactId>
        <version>${jboss.fuse.bom.version}</version>
        <type>pom</type>
        <scope>import</scope>
      </dependency>
    </dependencies>
  </dependencyManagement>

correct version

  <properties>
    ...
    <jboss.fuse.bom.version>7.2.0.fuse-720020-redhat-00001</jboss.fuse.bom.version>
    ...
  </properties>
  <dependencyManagement>
    <dependencies>
      <dependency>
        <groupId>org.jboss.redhat-fuse</groupId>
        <artifactId>fuse-karaf-bom</artifactId>
        <version>${jboss.fuse.bom.version}</version>
        ...
      </dependency>
    </dependencies>
  </dependencyManagement>

Environment

  • Red Hat Fuse 7.2
  • Red Hat CodeReady Studio 12.0

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In