openstackclient doesn't support volume API microversions

Solution Verified - Updated -

Issue

  • Various openstack ... commands print the following error when using --os-volume-api-version 3.xx or have OS_VOLUME_API_VERSION=3.xx environment variable:

    volume version 3.48 is not in supported versions: 1, 2, 3
    Invalid volume client version '3.48'. must be one of: 1, 2, 3
    
  • python-openstackclient doesn't support microversions for Volume API

Environment

  • Red Hat OpenStack Platform 10
  • Red Hat OpenStack Platform 13
  • Red Hat OpenStack Platform 14
  • Red Hat OpenStack Platform 15

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In