EAP 7 server unavailable in JBoss ON with "Unable to detect management port."

Solution Verified - Updated -

Issue

  • EAP server is discovered, imported into JBoss ON Inventory. Correct management user/password are entered on Connection Settings screen but the server still shows as unavailable

Environment

  • Red Hat JBoss Operations Network (ON) 3.3.11
  • Application Platform Management Plug-in Pack Update-09 for JBoss ON 3.3
  • Red Hat JBoss Enterprise Application Platform (EAP) 7.1.0
  • Http management interface is enabled on EAP server:
<management-interfaces>
            <http-interface security-realm="ManagementRealm">
                <http-upgrade enabled="true"/>
                <socket-binding http="management-http"/>
            </http-interface>
        </management-interfaces>
  • Message in agent.log:
WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Cannot start component for Resource[id=46047, uuid=a0042e5f-ec4c-4c8a-a6cd-2fb141fe4d60, type={EAP7}EAP7 Standalone Server, key=hostConfig: /jboss-eap-7.1/standalone/configuration/standalone-full-ha.xml, name=EAP 7 (127.0.0.1:9990), parent=server.example.com, version=EAP 7.1.0.GA] from synchronized merge due to invalid plugin config: Failed to start component for Resource[id=46047, uuid=a0042e5f-ec4c-4c8a-a6cd-2fb141fe4d60, type={EAP7}EAP7 Standalone Server, key=hostConfig: /jboss-eap-7.1/standalone/configuration/standalone-full-ha.xml, name=EAP 7 (127.0.0.1:9990), parent=server.example.com, version=EAP 7.1.0.GA] - Unable to detect management port. Please enable management HTTP interface on and then set correct port number in Connection Settings of this resource

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In