Why some subscriptions are not available in `Attach a subscription` page on customer portal ?

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Subscription-Manager(RHSM)

Issue

  • After registering system on customer portal using subscription-manager(RHSM) not able to attach subscription to it, Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Unlimited guests) subscription is not listed in Attach a subscription page.
  • The subscription Red Hat Enterprise Linux as a Virtual Guest (4 guests per server), Premium - 3 Year is not available on customer portal.
  • The JBoss Partner Developer Support for Global SIs subscription not available on portal.

Resolution

  • Some subscriptions are not supported by subscription-manager(RHSM), to know if subscription is supported or not contact Red Hat Technical Support.
  • For the supported subscriptions like Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Unlimited guests) which are not synced to the account, need to be synced manually by Red Hat technical engineers. To do this, raise the case with Red Hat Technical Support.
  • Workaround for this issue is to register system using RHN Classic.

Root Cause

  • Subscription is not supported by subscription-manager (RHSM).
  • Subscriptions are not synced to the account properly.
  • System has more sockets that what the subscription mentiones.

Diagnostic Steps

  • Register system using subscription-manager and check available subscriptions using,
 # subscription-manager list --available
  • Register system using subscription-manager and check available subscriptions in Attach a subscription page on customer portal.

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