How do I recover the missing JBoss server.log?
Environment
- Red Hat JBoss Enterprise Application Platform (EAP)
- 6.x
- 7.x
Issue
- JBoss EAP log file
server.log
is archived by a maintenance script and does exist anymore. - The log file is not automatically re-generated during server runtime hence all the logging messages are lost.
Resolution
- The easiest way is restarting the server. The
server.log
will be re-populated and start logging normally. -
If the server cannot be restarted (e.g Production environment), the logging subsystem can be reconfigured by below way:
/subsystem=logging/periodic-rotating-file-handler=FILE:write-attribute(name=file.path,value=server.log)
Backup the configuration files before running this command. After running above command, the new
server.log
could be re-populated.
Root Cause
- The log4j subsystem maintains the linkage between FileHandler and the current log file
server.log
. If any commands delete the log file, the linkage is broken and needs to be rebuilt.
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