Why ISO/EXPORT Domain is not getting attach after a fresh installation and restoring the old database?

Solution Verified - Updated -

Issue

  • While testing a backup/restore procedure for RHEV-Manager 3.1 we backed up all the configuration file and exported the database as described in this guide.

  • The database was then restored on the fresh RHEVM.

  • The ISO/EXPORT Domain fails to attach.

  • When trying to attach the ISO domain, following message is displayed:

    • Failed to activate Storage Domain ISO_DOMAIN (Data Center HDIT_TEST) by admin@internal.

    • Failed to refresh the following Iso domains : ISO_DOMAIN (ISO file type). Please check domain activity.

  • In /var/log/ovirt-engine/engine.log, below messages are logged:

2013-04-26 13:50:14,983 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (pool-3-thread-49) [62ff5e03] Failed in ActivateStorageDomainVDS method
2013-04-26 13:50:14,983 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (pool-3-thread-49) [62ff5e03] Error code StorageDomainDoesNotExist and error message IRSGenericException:
 IRSErrorException: Failed to ActivateStorageDomainVDS, error = Storage domain does not exist: ('193ead87-bf8c-4465-a4da-913bf82bbcd2',)
2013-04-26 13:50:14,983 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-3-thread-49) [62ff5e03] IrsBroker::Failed::ActivateStorageDomainVDS due to: IRSErrorException: IRSGe
nericException: IRSErrorException: Failed to ActivateStorageDomainVDS, error = Storage domain does not exist: ('193ead87-bf8c-4465-a4da-913bf82bbcd2',)

Environment

  • Red Hat Enterprise Virtualization 3.1

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content