Error happens frequently on JDBS when specifying 7.1.0 kie-maven-plugin in pom.xml of kjar maven project

Solution In Progress - Updated -

Issue

In my kjar maven project of Red Hat JBoss Developer Studio , the following kie-maven-plugin is set for RHPAM7.1.0.

  <build>
    <plugins>
      <plugin>
        <groupId>org.kie</groupId>
        <artifactId>kie-maven-plugin</artifactId>
        <version>7.11.0.Final-redhat-00003</version>
        <extensions>true</extensions>
      </plugin>
    </plugins>
  </build>

After that, the following error appears in some operations, such as Project -> Clean, edit pom.xml, building kjar.

Errors occurred during the build.
Errors running builder 'Maven Project Builder' on project 'xxxxx'.
Missing parameter for pluginExecutionFilter. groupId, artifactId, versionRange and goals must be specificed, but found: groupId = 'org.kie'
artifactId = 'kie-maven-plugin'
versionRange = '7.11.0.Final-redhat-00003'
goals = '[]'

This did not happen when kie-maven-plugin version was '7.7.0.Final-redhat-8' (RHPAM7.0.1).

Environment

  • Red Hat Process Automation Manager
    • 7.1.0
    • 7.1.1
  • Red Hat JBoss Developer Studio 11

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In