Red Hat Satellite upgrade to 6.4 fails with, Upstream username and password may only be set on custom repositories

Solution Verified - Updated -

Issue

  • Red Hat Satellite upgrade to 6.4 fails with any of the below errors :
ActiveRecord::RecordInvalid: Validation failed: Upstream username and password may only be set on custom repositories.
ActiveRecord::RecordInvalid: Validation failed: Upstream password requires upstream username be set.
  • Red Hat Satellite 6 upgrade fails at below step:
[ERROR 2018-10-29T08:49:09 main] foreman-rake katello:upgrades:3.8:clear_checksum_type failed! Check the output for error!
[ERROR 2018-10-29T08:49:09 main] Upgrade step clear_checksum_type failed. Check logs for more information.

Environment

  • Red Hat Satellite v.6.5
  • Red Hat Satellite v.6.4
  • Red Hat Satellite v.6.3.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In