Error on python2-openstacksdk when deploying Openshift using Ansible

Solution Verified - Updated -

Issue

  • A python2-openstacksdk version >= 0.12.0 is required for OpenStack playbooks in OCP 3.11 (Ansible 2.6).
  • The ansible 2.6 module os_networks_facts fails:
fatal: [localhost]: FAILED! => {"changed": false, "msg": "To utilize this module, the installed version ofthe openstacksdk library MUST be >=0.12.0"}

Environment

  • Red Hat OpenStack (OSP) 13
  • Red Hat Openshift (OCP) 3.11

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In