"WFLYJCA0069: At least one xa-datasource-property is required for an xa-datasource" when creating an XA datasource in JBoss EAP

Solution Verified - Updated -

Issue

  • Attempting to create an XA datasource in a domain's "full" profile via JBoss CLI with enabled=true

    [domain@localhost:9990 / #] /profile=full/subsystem=datasources/xa-data-source=TestXADS:add(...enabled=false...)
    
  • Encountering WFLYJCA0069: At least one xa-datasource-property is required for an xa-datasource

Environment

  • Red Hat JBoss Enterprise Application Platform (EAP) 7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In