Why yum repolist returns 0 for single repository on Red Hat Satellite 6?

Solution Verified - Updated -

Issue

  • On client registered to Red Hat Satellite server, The result of yum repolist for only a single repository is empty.
# yum repolist all
!rhel-7-server-optional-rpms/7Server/x86_64                     Red Hat Enterprise Linux 7 Server - Optional (RPMs)                                      enabled:      0
rhel-7-server-rhn-tools-rpms/7Server/x86_64                     RHN Tools for Red Hat Enterprise Linux 7 Server (RPMs)                                   disabled
!rhel-7-server-rpms/7Server/x86_64                              Red Hat Enterprise Linux 7 Server (RPMs)                                                 enabled: 20,922
!rhel-7-server-satellite-tools-6.2-rpms/x86_64                  Red Hat Satellite Tools 6.2 (for RHEL 7 Server) (RPMs)                                   enabled:    146
rhel-7-server-supplementary-rpms/7Server/x86_64                 Red Hat Enterprise Linux 7 Server - Supplementary (RPMs)                                 disabled
rhel-server-rhscl-7-rpms/7Server/x86_64                         Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server                  disabled
  • rhel-7-server-optional-rpms repository is empty from the above output.

Environment

  • Red Hat Satellite 6.X

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In