Perl CPAN module inconsistencies when using the EPEL YUM repository

Solution Unverified - Updated -

Issue

The Perl CPAN Scalar::Util module shipped with Red Hat, and with the unsupported "EPEL" yum community repository are at different versions.

When users upgrade Perl CPAN packages, and they have different versions of the Perl CPAN Scalar::Util module, they can experience related application instabilities and failures.

Error 500 has been reported due to this, after upgrading RHEL with EPEL repos enabled.

Environment

  • Red hat Enterprise Linux Version 5.9

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content